Перейти к содержимому


Fix для UOsteam


  • Авторизуйтесь для ответа в теме
В этой теме нет ответов

#1 Necron

Necron

    Journeyman

  • Members
  • 66 сообщений
  • Пол:Мужчина
  • Город:Минск

Отправлено 06 Ноябрь 2016 - 09:55

Возможно я не первый кто сталкивается с данной ошибкой при старте UOsteam - выскакивает окошко в котором программа ругается на virtual memory,вот несколько решений данной проблемы (прошу администрацию закрепить в теме этот пост).


Fix #1 - Set your Virtual Memory to 3x what the physical amount is, reboot and try again. (at one point I had 75gb of Virtual Mem and it didn't help)
Fix #2 - Close every program currently running and try UOSteam again.
Fix #3 - Set compatibility mode of UOSteam to WinXP SP3.
Fix #4 - Run UOSteam as Admin.
Fix #5 - Open Task Manager and close unneeded processes that are running (this one has the capability of being dangerous if you close the wrong thing)
Fix #6 - Run msconfig.exe and rid your system of unneeded Startup processes.

NONE of these worked for me as stated. #5 and #6 worked for me somewhat but I had to take it a step further.

To get UOSteam to work, I had to:
1. Run msconfig.exe
2. Select Startup tab.
3. Uncheck ALL items that are not necessary. Some items you may see are Java Auto Updater, iTunes, Google Talk; things of this nature do not need to startup when the system does. It's handy that they do so, but not necessary.
4. Reboot system for a fresh start.
5. Once system is back up to desktop, open Task Manager again.
6. Select the Processes Tab.
7. Click the Memory heading to sort highest to lowest memory usage, at the top (on my system anyway) was svchost.exe as using the most memory. (I won't go into it all but you can drill further down with Procmon and other tools to find exactly what is being called into memory from each process but I was impatient and just went on with....)
8. Select the top process of svchost.exe and clicked End Process. (if svchost.exe isn't the process using the most Memory, find the svchost.exe (there are several) that is using the most and End Process on it)

You are shooting for the lowest amount of Memory in use prior to starting up UOSteam. This got my memory below 19% usage and UOSteam fires up everytime for me following my "Kill the svchost.exe after a Fresh Reboot" Plan.

Now when I want to fire up UOSteam I only need to do the following: (this is where the fixes listed at the top start to coincide with reality for me and my computer)
1. Close all programs.
2. Open Task Manager and kill highest svchost.exe
3. Fire up UOSteam.
4. Bask in the glory of Excelsior.

The svchost.exe process that is using the most memory generally doesn't contain anything critical to the running of your system but the best way is to use a tool to see what it's calling and make sure. Not all svchost.exe's are the same and End Process on the wrong one can cause a system crash.

Ultimately, my system is messy internally and it is my own fault that I had the UOSteam issues that I've had. If I were a good Tech I would reformat my home system more often but I do this crap all day long at work, when I get home I really don't have the desire to muck about with OS's, hardware and etc.; I just want to have some fun playing a game and relax.

Anyway, I've posted this in case it might help someone. Please use your own discretion if you choose to use what I've done. I don't remember everyone's name, but there are several folks at Excelsior that I've talked to in game that have a lot of good info as well. Hopefully they will reply to this thread with their ideas also.

(if more detail is needed, just holler. I've only given a general overview of things here.)
Lowne in game.
Archer, Tamer and Long-winded Idiot.
Lowne




Количество пользователей, читающих эту тему: 0

0 members, 0 guests, 0 anonymous users